Remove Ads Button Weirdness

Discussion in 'Technical Discussion' started by Phill Mason, May 2, 2017.

  1. Phill Mason

    Phill Mason Serious Boxer

    Joined:
    Sep 25, 2015
    Messages:
    880
    Likes Received:
    719
    Hi folks, I've added a Remove Ads Button in my store. I have links to the store from the main menu screen and also on the game over screen.

    Issue:
    When I click on the store button from the main menu, I can see the remove ads button no problem and I know when I click on it, it disappears, so I have a black and white version of the button hidden behind it and this works really well.

    I also have a link to the store from the game over screen and if I click into the store from the game over screen, the remove ads button is already showing my black and white image, as if I have already used the remove ads button.

    Clearly this shouldn't be the case. Anyone have any idea what I may be missing here, or is this a bug?

    I've tried in on the last three available versions and it's the same on all of them. Cheers.
     
  2. blad300

    blad300 Serious Boxer

    Joined:
    Oct 8, 2015
    Messages:
    515
    Likes Received:
    276
    What i understand is , you have 2 Remove Ads buttons,
    One in Main Menu and one is in Game Over ?
    If you "Remove Ads" once from Main Menu, the button from Game Over have the same thing "to do", so is remove it also .
    You want to remove ads twice ?
     
    Phill Mason likes this.
  3. Phill Mason

    Phill Mason Serious Boxer

    Joined:
    Sep 25, 2015
    Messages:
    880
    Likes Received:
    719
    Hey @blad300, thanks for chiming in. No, I don't want to remove ads twice. I have only 1 x remove ads button on my store page, but you can get to the store from either the main menu, or the game over screens. If I go to the store via main menu, the buttons is showing correctly as not being used, if on the other hand I go to the store via the game over page, the remove ads buttons displays as if it's been used - even though I haven't yet used that button anywhere.

    This is the confusing part. If I haven't yet pushed the remove ads button in the store, regardless of how many pages I use to link the a shop/store, the button should still be active and ready for use.

    I think this maybe a bug. Have you heard/experienced anything odd like this @Andy?
     
  4. Andy

    Andy Miniboss Boxer

    Joined:
    Sep 24, 2015
    Messages:
    2,152
    Likes Received:
    1,545
    I don't recall that this has come up before, but it's possible.

    Part of this might be not being abe to have the button on multiple screens. Obviously, that should be fixed, but it sounds like the state is only being saved on the screen it being used on. But it sounds like that is only part of the issue. If you only have the button in one place does everything always work as expected?
     
  5. Phill Mason

    Phill Mason Serious Boxer

    Joined:
    Sep 25, 2015
    Messages:
    880
    Likes Received:
    719
    The remove ads button is only in one place, in the store. But as I've mentioned above, you can get to the store from either the main menu, or the game over screen.
     
  6. heathclose

    heathclose Miniboss Boxer

    Joined:
    Jan 28, 2016
    Messages:
    1,810
    Likes Received:
    1,024
    is it always this way no matter how many times you restart... I'm just wondering if there is some data being saved in the /Docements/UserDefault.xml file that keeps track of second play and all that... or it's possible I'm just completely misunderstanding the issue.
     
    Phill Mason likes this.
  7. Christoph

    Christoph Miniboss Boxer

    Joined:
    Oct 4, 2015
    Messages:
    2,808
    Likes Received:
    2,308
    Is this in 2.2.9? I'm not sure anymore what version I have used for Void Jumping but I have the remove ads button in several UIs and never had a problem. Actually if you remove it in the settings it doesn't appear anymore in the game over UI and viceversa. I think it might have been BB2.2.7... But this was working before with several remove ad buttons and by accessing them from different places like you say, from the main menu and from the game over screen...
     
    Phill Mason likes this.
  8. trudnai

    trudnai Miniboss Boxer

    Joined:
    Sep 25, 2015
    Messages:
    1,234
    Likes Received:
    696
    You are absolutely right, Phill. Having said that I do not see a problem with this on my game. I still use 2.2.9 Beta 2.
     
    Phill Mason likes this.
  9. blad300

    blad300 Serious Boxer

    Joined:
    Oct 8, 2015
    Messages:
    515
    Likes Received:
    276
    Like how @heathclose say, maybe is there some data saved, like you already use that button!
    Same problem on multiple devices ?
    and ... do you use 2.2.9?
     
    Last edited: May 2, 2017
    Phill Mason likes this.
  10. Phill Mason

    Phill Mason Serious Boxer

    Joined:
    Sep 25, 2015
    Messages:
    880
    Likes Received:
    719
    Yes I used and tested in V2.2.9 all beta's, plus 2.2.8 and 2.2.7 - all with the same odd result.
    ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

    **Update - Fixed**

    This has been a weird one folks and thank you @blad300, @Andy @heathclose @Christoph and @trudnai for all your input.
    I'm afraid this isn't a solution for anyone else who may experience this, but I have fixed it through trial and error.

    I've basically rebuilt the store screen and the remove ads button is now displaying as it should be when linked from the game over screen. I can only assume that somewhere along the building/creation stage of the store, there was some kind of odd loop created from main menu to store and from game over screen to store, as everything I tried, I still got the "used" remove ads button from the game over screen.

    To test things out, I created new store buttons from both my info page and more page and linked these to the store. Upon clicking these and arriving at the store page, the remove ads button was fine, just as it was from the main menu. Yet, the link to the store from the game over screen still showed me a used remove ads button, so I assumed the issue was on this screen.

    I deleted the store link from the game over screen and created a new store button and named the button "store 01" to differentiate it from the others, but linking to the store from this new button, still greyed out the remove ads button in the store - this was bonkers and didn't make any sense.

    My final test was, I created a new "Test Store" page, placed only the remove ads button on it and linked to this page from my game over screen. Upon testing this out, everything worked perfectly. So which button/UI/page was to fault? I have no idea.

    My assumptions are, perhaps through creating certain pages and buttons in one version of BB, then backing up and testing a new copy of that BBdoc and continuing to build the game by creating new links, new UI's more buttons, new scenes etc in another version of BB, had created some kind of code-funkiness behind the scenes that was not obvious to me, who can say.
     
    trudnai and blad300 like this.
  11. blad300

    blad300 Serious Boxer

    Joined:
    Oct 8, 2015
    Messages:
    515
    Likes Received:
    276
    Happy dev then :p
     
    Phill Mason likes this.
  12. heathclose

    heathclose Miniboss Boxer

    Joined:
    Jan 28, 2016
    Messages:
    1,810
    Likes Received:
    1,024
    @Phill Mason he put on that dress... gave him super dev powers
     

Share This Page