I Need Help Please

Discussion in 'Technical Discussion' started by patostar, Mar 19, 2018.

  1. patostar

    patostar Avid Boxer

    Joined:
    Jan 27, 2018
    Messages:
    450
    Likes Received:
    78
    When I export any game from 2.3.0 I don't see any ads, I changed admob ids many times, I tried to export from 2.2.8 but the problem still exists, I made a game a few month ago with this package name: com.gamesentertainment.quizgame

    When I export any game to android (I am using windows 8.1) with this package name I can see the ads, but when I change the package name the ads no longer show in the game, is eclipse the problem? it's really weird, anything exported with this package name works perfectly with ads, but when I just change the package name the ads disappear :((
     
  2. spicedbeangames

    spicedbeangames Miniboss Boxer

    Joined:
    Mar 31, 2016
    Messages:
    1,303
    Likes Received:
    550
    If you change the package name, you need to also create a new Ad campaign for it. Each ad campaign is tied to your package name. It's not a case of just logging into your Advertiser of choice either and change the package name there. You just need to duplicate the settings for the current adverts you are showing and apply them to a new package name.
     
  3. TheGameAppStudio

    TheGameAppStudio Serious Boxer

    Joined:
    Nov 2, 2016
    Messages:
    833
    Likes Received:
    256
    Hi,I thought about this the moment question was raised but was waiting for someone to answer :p .But could this be a issue ? If its a admob itsn't necessary to add package name while setting up ads(unless its been linked to existing published game)So in that case no matter what ads would show.And same for Heyzap too since it display on publisher id.
    That's what i understood.
     
  4. patostar

    patostar Avid Boxer

    Joined:
    Jan 27, 2018
    Messages:
    450
    Likes Received:
    78
    Hello, thanks for your answers both of you, look I created new admob ad ids, but when I change the package name to a name that I never used before the ads are still not showing, when I use old package name the ads show in the game ! I don't understand why this is happening,
     
  5. spicedbeangames

    spicedbeangames Miniboss Boxer

    Joined:
    Mar 31, 2016
    Messages:
    1,303
    Likes Received:
    550
    I would check spelling, spaces, blanks in the IDs just to make sure. Otherwise you are best off contact AdMob or whoever the ad platform is to see if they can test their end. Or, trying google the problem. That's how I solve 85% of my problems
     
  6. TheGameAppStudio

    TheGameAppStudio Serious Boxer

    Joined:
    Nov 2, 2016
    Messages:
    833
    Likes Received:
    256
    Hi,is the new package name in both admob and buildbox same?Kindly check it.Like @spicedbeangames mentioned look for spelling ;)
     
  7. patostar

    patostar Avid Boxer

    Joined:
    Jan 27, 2018
    Messages:
    450
    Likes Received:
    78
    Hi, sorry for the late reply, but yes of course I am using the same ads id, I checked spellings a lot, I don't know what to do! I've been searching a lot believe me I haven't found any solution, there is something wrong either with my buildbox, or eclipse, but my admob account is 100 % safe, no violations at all
     
  8. spicedbeangames

    spicedbeangames Miniboss Boxer

    Joined:
    Mar 31, 2016
    Messages:
    1,303
    Likes Received:
    550
    Solution is to keep the old package name if it works. I haven't a clue why this is happening. Your only other option is to throw the ad network support team an email with the problem - see if they can help.
     

Share This Page