Game Is Lagging While Testing

Discussion in 'Buildbox 3.0' started by Kanishk Sachdeva, Dec 14, 2018.

  1. Kanishk Sachdeva

    Kanishk Sachdeva Avid Boxer

    Joined:
    Jul 10, 2018
    Messages:
    217
    Likes Received:
    16
    I am using BB3 Beta 4 , until now when exporting and testing on my iPhone game was working perfectly but now suddenly game is lagging too much ( continuously , like it has slowed down and is playing at that rate only ) It is working fine in preview but lagging while testing on iPhone.
    Can anyone suggest me what to do ?
     
  2. AntiStudio

    AntiStudio Boxer

    Joined:
    Oct 26, 2018
    Messages:
    2
    Likes Received:
    1
    Mine is lagging both when creating and in preview since the latest update. Machine is certainly not the issue :/
     
  3. Kanishk Sachdeva

    Kanishk Sachdeva Avid Boxer

    Joined:
    Jul 10, 2018
    Messages:
    217
    Likes Received:
    16
    Mine as well after the last update.
    I mailed to support but got no solution from them ?
    Have you mailed to them ? If you find a solution in future please post it here.
     
  4. spicedbeangames

    spicedbeangames Miniboss Boxer

    Joined:
    Mar 31, 2016
    Messages:
    1,340
    Likes Received:
    560
    Try cleaning your files etc. And look at how your connections with the nodes are going. Perhaps too much is going on, or some of the logic isn't logical. Send your bb doc to support and they can take a look.
     
  5. Kanishk Sachdeva

    Kanishk Sachdeva Avid Boxer

    Joined:
    Jul 10, 2018
    Messages:
    217
    Likes Received:
    16
    What do you mean by cleaning your file ? By the way my file size is just 3-4 mb. ( bbdoc ) so it's definitely not large.
    Also I don't think that this is happening because of some error in nodes because up until now it was working perfectly , it just happened to work in a weird manner right now.
     
  6. shadowkiller

    shadowkiller Boxer

    Joined:
    Oct 26, 2018
    Messages:
    7
    Likes Received:
    0
    same for me
     
  7. Kanishk Sachdeva

    Kanishk Sachdeva Avid Boxer

    Joined:
    Jul 10, 2018
    Messages:
    217
    Likes Received:
    16
    Has anyone figured out a solution for this ?
     
  8. Kanishk Sachdeva

    Kanishk Sachdeva Avid Boxer

    Joined:
    Jul 10, 2018
    Messages:
    217
    Likes Received:
    16
    I am still experiencing this, any solutions ?
     
  9. spicedbeangames

    spicedbeangames Miniboss Boxer

    Joined:
    Mar 31, 2016
    Messages:
    1,340
    Likes Received:
    560
    Firstly, you've got to stop making several posts about the same problem. It creates confusion and splits up answers/solutions. You will really need to post screenshots, and more information about your system/device you're testing on. There could be a host of reasons, including the BB software but it could be other factors.

    When I say files, it could be how you have used the nodes, are there too many trying to do a simple task?
     
  10. Kanishk Sachdeva

    Kanishk Sachdeva Avid Boxer

    Joined:
    Jul 10, 2018
    Messages:
    217
    Likes Received:
    16
    This is the only post that I have created for this problem , I can’t control if other boxers create a similar thread regarding this problem without searching and finding an already created similar post.
    Tell me what screenshots do you need I will post that , and also I am testing it on my iPhone 6s ( you asked for device information , ask specifically for more information if you need ) .

    Nodes have not been changed in about 3 weeks and have remained same ( before the problem was there and now that the problem is there ) so nodes causing this suddenly is a little weird.

    Also same problem is there when I am testing it on an Android Device ( which is new and not as old as iPhone 6s )
     
  11. spicedbeangames

    spicedbeangames Miniboss Boxer

    Joined:
    Mar 31, 2016
    Messages:
    1,340
    Likes Received:
    560
    So then you need to narrow down where the problem is. Where in the game does it slow down? Is it from the start? If so take a look at your first scene and check there. Test the character controller, maybe untag some nodes and build to test etc. Its a process of elimination. Otherwise send your bbdoc to support to look at but remember its the holidays.
     
  12. Kanishk Sachdeva

    Kanishk Sachdeva Avid Boxer

    Joined:
    Jul 10, 2018
    Messages:
    217
    Likes Received:
    16
    Yes the game slows down from the start.
    Do you want me to untag and then retag the nodes like they were ?
    What does build to test mean and how do you do it ?
    I will send my bbdoc to support team now.
     
  13. omer

    omer Boxer

    Joined:
    Oct 1, 2018
    Messages:
    9
    Likes Received:
    2
    I'm having this issue since a very long time when exporting my game to andriod device. The game works perfectly when I preview on bb3 but when exporting to andriod studio and test it there the game just runs slows on my device. I don't think it has to do with the nodes because there is no way all of us having wrong nodes. Also, multiple boxers are experiencing the same problem.
     
    Last edited: Jan 4, 2019

Share This Page