Bb3: Game Crushes After About 10 Mins Of Running

Discussion in 'Buildbox 3.0' started by Ilya Skapchuk, Sep 5, 2019.

  1. Ilya Skapchuk

    Ilya Skapchuk Boxer

    Joined:
    Mar 19, 2019
    Messages:
    7
    Likes Received:
    2
    Hi guys,

    Who can help?
    My game crushes after about 10 mins of running.
    I've connected my iPhone to computer and ran game via Xcode.
    I see error in Xcode when game crushing (See attachment)

    Does anyone know what this error means?
    Really needed, I have to lunch my game public in next week
     

    Attached Files:

    • 1.png
      1.png
      File size:
      652.4 KB
      Views:
      10
  2. Sean Buildbox

    Sean Buildbox Administrator Staff Member

    Joined:
    Sep 24, 2015
    Messages:
    634
    Likes Received:
    717
    Using 3.0.1 #3163 ? Is it at the same specific point? A lot of that time it is a memory issue, but not always. You can send bbdoc file and details to support@buildbox.com and we will be more than happy to dig deeper and assist ;)
     
  3. Ilya Skapchuk

    Ilya Skapchuk Boxer

    Joined:
    Mar 19, 2019
    Messages:
    7
    Likes Received:
    2
    Hey,
    Yes, I use 3.0.1 B#3163

    "Is it at the same specific point?" - I noticed 2 times at the same level (17th for my game).
    At the same time I can pass 60 level at once with no crashing.

    Sent email to support with Xcode error screenshot. Waiting for answer.
     
    Sean Buildbox likes this.
  4. Ilya Skapchuk

    Ilya Skapchuk Boxer

    Joined:
    Mar 19, 2019
    Messages:
    7
    Likes Received:
    2
    I found in Console that at the moment of crushing it refers to mediaserverd (CoreAudio), Subsystem: com.apple.coreaudio, Category: AudioHAL_Server
    upload_2019-9-7_19-32-51.png
    Does anyone know how to fix it?
     
  5. Scriv

    Scriv Boxer

    Joined:
    Oct 28, 2018
    Messages:
    50
    Likes Received:
    21
    sometimes your phone can shut a program if it is causing it to overheat. if you have a lot of untamed variables, hi poly obj models, that sort of thing... You could try stripping the game incrementally to see if the problem continues?
     

Share This Page