Remove Ads Button Causes Strange Errors

Discussion in 'In App Purchases' started by juan123, Aug 19, 2018.

  1. juan123

    juan123 Boxer

    Joined:
    Mar 24, 2018
    Messages:
    3
    Likes Received:
    0
    Hello,

    I have added a remove ads button in my game, and the ads do disappear after buying the item. However, after closing the game, and then trying to restart it, a lot of different errors occur. I have been testing the game on two devices:

    Samsung Galaxy S7 Edge:
    The game cannot be restarted after removing ads. I can see the splash screen and then the game crashes every time I try to start it. When I uninstall the game I am able to open it again and then I can see ads. However, when clicking on "Restore Purchases" the ads disappear as expected but then again I am not able to start the game after closing it.

    Samsung Galaxy S4:
    Everything seems to be working. The ads disappear after purchase. I can also restart the game and the ads are still removed. However, the music in my game is muted every time I restart the app after the ads have been removed. In order to reactivate the music I have to click on the "mute audio" button and then "unmute audio" button each time I start the game. This only happens after purchasing "remove ads".

    Does anyone know how to solve this?
     
  2. juan123

    juan123 Boxer

    Joined:
    Mar 24, 2018
    Messages:
    3
    Likes Received:
    0
    Oh, and I forgot to mention that it works perfectly fine on iOS. But not Android. o_O
     
  3. TheGameAppStudio

    TheGameAppStudio Serious Boxer

    Joined:
    Nov 2, 2016
    Messages:
    859
    Likes Received:
    264
    Hi,whats your buildbox version?
     
  4. Kanishk Sachdeva

    Kanishk Sachdeva Avid Boxer

    Joined:
    Jul 10, 2018
    Messages:
    217
    Likes Received:
    16
    Hi, about to release my game soon. Just want to know are you still experiencing this. Or did you find any solution to this or not.
    Just to prevent me from having similar kind of thing. By the way I am using BB3 Beta 4.
     

Share This Page