Problem With Admob Ads

Discussion in 'Technical Discussion' started by Bilz636, Mar 28, 2018.

  1. Bilz636

    Bilz636 Avid Boxer

    Joined:
    Oct 5, 2015
    Messages:
    308
    Likes Received:
    180
    HI guys

    Admob ads (Banner and Interstitial ) are not showing in my game (bb2.3.3).
    I double check the admob account and all ads units, which are working fine with other games (was exported by bb2.3.2 i guess).

    I tried to add custom code in manifast but still no lead on it (only for troubleshooting purpose).


    Does anyone know whats wrong?


    EDITED:

    Untitled.png
     
    Last edited: Mar 28, 2018
  2. ZackGriset

    ZackGriset Administrator Staff Member

    Joined:
    Oct 3, 2017
    Messages:
    246
    Likes Received:
    334
    There does seem to be something off here. I just double checked it on my end and I'm seeing something similar. Can you please email this into support so we can document this and dive into it? Any other information that you can give us will be really helpful too.
     
  3. Bilz636

    Bilz636 Avid Boxer

    Joined:
    Oct 5, 2015
    Messages:
    308
    Likes Received:
    180
    Sure please check your inbox (Support@buildbox.com)


    One thing more i forget to write in email

    Why the Hell Checkpoint is not working?
     
  4. ZackGriset

    ZackGriset Administrator Staff Member

    Joined:
    Oct 3, 2017
    Messages:
    246
    Likes Received:
    334
    Okay great. We will check on it.

    Checkpoints should be working fine. If you are having a problem with it or any future issues at all, please send them into support with a bbdoc and any screenshots that might be helpful. The way you just asked me isn't the best approach.
     
  5. and249

    and249 Avid Boxer

    Joined:
    Sep 30, 2017
    Messages:
    242
    Likes Received:
    108
    Hi @ZackGriset! I want to show you something but I can't send you any message in the forum. It says that "You should not send a message to ZackGriset"
     
  6. ZackGriset

    ZackGriset Administrator Staff Member

    Joined:
    Oct 3, 2017
    Messages:
    246
    Likes Received:
    334
    whaaaaaat?! really?! Okay I need to look into this. You should be able to message me anytime. Let me see what I find
     
  7. volcank

    volcank Serious Boxer

    Joined:
    Oct 8, 2015
    Messages:
    721
    Likes Received:
    339
    Hi @ZackGriset @Bilz636 I am also having problems showing admob ads. I tried both ways (heyzap and regular) and still it doesn’t work. Might be something with banner maybe because it also doesn’t show heyzap banner at all. At android I was able to see a banner like 5 minutes so and it eas gone. At ios still nothing! Did anyone found a solution? Thank you
     
  8. Bilz636

    Bilz636 Avid Boxer

    Joined:
    Oct 5, 2015
    Messages:
    308
    Likes Received:
    180
    Zack did you check the problem?
    I just resend the file because i am not getting any support ticket (automated) so i thought maybe did not delivered.
     
  9. ZackGriset

    ZackGriset Administrator Staff Member

    Joined:
    Oct 3, 2017
    Messages:
    246
    Likes Received:
    334
    I'm looking into this today. The part where the banner appears for only around 5 minutes on android is super weird. I'll let you know what I find.

    Hey man, we had a lot of support emails yesterday, so we are getting to it, we are just catching up. I'm looking into this again today. I started looking into it a little already, and I was having a similar problem, but now I need to figure out how to fix it. I'll get back to you ASAP
     
    volcank and Bilz636 like this.
  10. volcank

    volcank Serious Boxer

    Joined:
    Oct 8, 2015
    Messages:
    721
    Likes Received:
    339
    Hi @ZackGriset ok I am taking it back and sorry for late reply. The admob works ok at Android and at IOS still nothing. I had to integrate facebook ads for banners for the time being. Thank you.
     
  11. ZackGriset

    ZackGriset Administrator Staff Member

    Joined:
    Oct 3, 2017
    Messages:
    246
    Likes Received:
    334
    Okay guys, so I did some major checking on this and there is definitely something a little fishy. I want to check on this more and bring this up to the dev team on Monday. I do think you can make it work at this point though. Let me address this with you guys:

    @volcank I tested admob banners and interstitials on xcode and it worked, but there is one thing I noticed. It took a really, really long time for Admob to provide me with an ad. They straight up did not have one queued up for like 20 mins at least. This might be because they just didn't have an ad for me or it might be my region, because in certain regions they provide less ads. I'm not sure exactly why admob was taking so long. Usually, it's been pretty good. I think this could be part of your issue for iOS. I think it might just be taking a long time and you have to check over and over again before anything shows up. Be patient and keep trying. If you've been waiting a super long time and it's still not working, then get back to me and I'll try and see if there is anything I can do when I get back on Monday.

    @Bilz636 So I saw from your first screenshot that you got rid of the commented out parts under admob. That's when the red line appeared and there was an error. Can you please try removing these lines of code and seeing if it works? It should. Here are the lines of code to remove:

    <activity
    android:name="com.vungle.publisher.FullScreenAdActivity"
    android:configChanges="keyboardHidden|orientation|screenSize"
    android:theme="@android:style/Theme.NoTitleBar.Fullscreen"/>

    Get rid of all that and try again. Let me know if it works. If you're still having trouble with this. I'll hook back up with you on Monday and help you out.
     
  12. Bilz636

    Bilz636 Avid Boxer

    Joined:
    Oct 5, 2015
    Messages:
    308
    Likes Received:
    180
    ok thanks for response @zeck
    I will let you know on this Monday because of the Weekend and i have buildbox access only in office PC
     
  13. AaroArts

    AaroArts Miniboss Boxer

    Joined:
    Jun 22, 2016
    Messages:
    1,532
    Likes Received:
    816
    For iOS, you can try Resetting Advertising Identifier in Settings/Privacy/Advertising/Reset Advertising Identifier.

    Sometimes if your device has been recieving a lot of targeted Ads, it won’t display one because it hasn’t found a relevant Ad.
    It seems linked to Admob IDs sometimes if you’ve regularly made a large amount of calls to your Device (for example regularly testing Xcode builds).
    It’s good practice to use Test IDs until your final Export from BB.

    Just note if you Reset it, you will reset all information gathered to issue you with targetted Ads, meaning future Ads you see may be less relevant to you.
     
    ZackGriset, Christoph and volcank like this.
  14. volcank

    volcank Serious Boxer

    Joined:
    Oct 8, 2015
    Messages:
    721
    Likes Received:
    339
    @ZackGriset Thank you so much for the reply and yes you are right! today finally admob started to serve ads inside my game. so basically it took like more than 24 hours for admob ads to appear.
     
  15. volcank

    volcank Serious Boxer

    Joined:
    Oct 8, 2015
    Messages:
    721
    Likes Received:
    339
    @AaroArts Thank you so much for the tip! I will remember this for the future.
     
  16. Bilz636

    Bilz636 Avid Boxer

    Joined:
    Oct 5, 2015
    Messages:
    308
    Likes Received:
    180

    All Ads working fine now after removing these code lines you maintained. Thanks man

    So what's the issue?
     
  17. ZackGriset

    ZackGriset Administrator Staff Member

    Joined:
    Oct 3, 2017
    Messages:
    246
    Likes Received:
    334
    Awesome man! That's great to hear. :) The problem was with those three lines. They either needed to stay commented out or deleted. We are going to make adjustments to it in our next release so this doesn't come up again.

    Woohoo! Awesome, thanks for letting me know. :) Yeah, it can take so long that you begin to think something is wrong sometimes. Definitely listen to the solid advice @AaroArts gave.
     
    volcank likes this.
  18. Bilz636

    Bilz636 Avid Boxer

    Joined:
    Oct 5, 2015
    Messages:
    308
    Likes Received:
    180
    ok @zeck I've got another problem. I wont like to spam forum by creating new threat for this.
    I had to install new Windows to remove shitty ads virus lol

    After reinstalling windows and Android studio (i used save SDk which i had backup already).
    Now i am getting these errors
    i can build APk when i follow the error instruction (to add BuildToolsVersion="27.0.3" )but still i thought maybe i am missing something that i dont know because i did not had these problem before.

    2.PNG 1.PNG
     
  19. ZackGriset

    ZackGriset Administrator Staff Member

    Joined:
    Oct 3, 2017
    Messages:
    246
    Likes Received:
    334
    If you reinstalled Windows, then there is a good chance you needed to re-download the build tools. But, it seems like from your description, that you didn't have to download the builds tools, but rather, you had to change the code from 26.0.2 to 27.0.3. So where are you at with this currently? Is it working properly now after you made that change to the code and you're just confirming that it's the correct thing to do? It does seem a little fishy. You shouldn't have to change the code at all to make it work.
     
  20. Bilz636

    Bilz636 Avid Boxer

    Joined:
    Oct 5, 2015
    Messages:
    308
    Likes Received:
    180
    APK build works when i change the BuildToosVersion And yes i did not download SDKs freshly i used old one.
    Fishy part might be the permission which i believe it should not cause any problem
    i remove these permission to upload APK into googlestore
    ACCESS_WIFI_STATE,
    ACCESS_COARSE_LOCATION
    READ_PHONE_STATE


    Should i download SDKs again?
     

Share This Page