My Game Does Not Start On Android Devices.

Discussion in 'How Can I...?' started by PlayShaft, Apr 3, 2018.

  1. PlayShaft

    PlayShaft Boxer

    Joined:
    Jul 5, 2017
    Messages:
    80
    Likes Received:
    44
    Hello! My APK does not start on Android devices. Gives an error message. Maybe someone had such a problem?

    I'm using the latest version of Android Studio and the latest version of Java.

    Android Studio issues a warning, but I'm not sure that the game does not work because of this.
    Configuration 'compile' is obsolete and has been replaced with 'implementation'.
    It will be removed at the end of 2018

    Unfortunately I did not find the answer on the forum, but I understand that the problem is in Google Serves. Help please solve this problem.

    [​IMG]
     
    Last edited: Apr 3, 2018
  2. spicedbeangames

    spicedbeangames Miniboss Boxer

    Joined:
    Mar 31, 2016
    Messages:
    1,347
    Likes Received:
    565
    Android has many versions. If you only download the latest SDK version, the game will ONLY work on devices using the latest version. As an example. If you have a phone with Android 4.1, the game will not work. You need to download the SDK for each version you wish to support.

    There's a bunch of arguments how low you should go with 2.3 Gingerbread being the lowest - but it doesnt support many features. 4.0/4.1 tends to be the standard right now.

    I am not sure about the 'compile' issue but that shouldnt prevent the app from launching. You can read more about your problem here
     
  3. PlayShaft

    PlayShaft Boxer

    Joined:
    Jul 5, 2017
    Messages:
    80
    Likes Received:
    44
    My game supports versions 3.0 - 8.1. The overlay is Android 4.4.
    I do not think that this is the case. I tried to open on Android 6. The game did not start.
     
  4. spicedbeangames

    spicedbeangames Miniboss Boxer

    Joined:
    Mar 31, 2016
    Messages:
    1,347
    Likes Received:
    565
    Did you download the all the SDKs to support all of the Android versions?
     
  5. PlayShaft

    PlayShaft Boxer

    Joined:
    Jul 5, 2017
    Messages:
    80
    Likes Received:
    44
    No, from 3.0 to 8.1
     
  6. Bilz636

    Bilz636 Avid Boxer

    Joined:
    Oct 5, 2015
    Messages:
    308
    Likes Received:
    180
    You can test your APK with Emulator like Bluestack if still does not run the game then try to Delete old Sdks and download fresh one.
    Yesterday i had the similar error but now i have fixed it by reinstalling all SDKs API 26.
    Also while compiling your game into APK please make sure you select V1

    here some useful reference you may like to see
    https://www.buildbox.com/forum/index.php?threads/problem-with-admob-ads.12465/#post-68270

    https://www.buildbox.com/forum/index.php?threads/apk-crash-after-compiling-bb2-3-2.12182/#post-66226
     

Share This Page