Ios Build Submit

Discussion in 'Technical Discussion' started by shayeb, Oct 27, 2017.

  1. shayeb

    shayeb Boxer

    Joined:
    Apr 2, 2017
    Messages:
    37
    Likes Received:
    0
    so i exported to ios and i did everything but when i go to itunes connect and add an app after it asks me about the Submit your builds using Xcode 6 or later, or Application Loader 3.0 or later. i already did it but nothing is showing up and when i try to submit it again it doesn't work because i already did it can anyone help me please?
     

    Attached Files:

  2. shayeb

    shayeb Boxer

    Joined:
    Apr 2, 2017
    Messages:
    37
    Likes Received:
    0
    I checked my email and i got this.


    Dear developer,

    We have discovered one or more issues with your recent delivery for "SOCCER LIT". To process your delivery, the following issues must be corrected:

    Missing Info.plist value - A value for the Info.plist key 'CFBundleIconName' is missing in the bundle 'com.SoccerLit.SoccerLit'. Apps built with iOS 11 or later SDK must supply app icons in an asset catalog and must also provide a value for this Info.plist key. For more information see http://help.apple.com/xcode/mac/current/#/dev10510b1f7.

    Once these issues have been corrected, you can then redeliver the corrected binary.

    Regards,

    The App Store team
     
  3. shayeb

    shayeb Boxer

    Joined:
    Apr 2, 2017
    Messages:
    37
    Likes Received:
    0
    idk what to do
     

    Attached Files:

  4. wesam_badr

    wesam_badr Miniboss Boxer

    Joined:
    Oct 10, 2015
    Messages:
    1,064
    Likes Received:
    479
  5. shayeb

    shayeb Boxer

    Joined:
    Apr 2, 2017
    Messages:
    37
    Likes Received:
    0
    idk its not working
     
  6. Andy

    Andy Miniboss Boxer

    Joined:
    Sep 24, 2015
    Messages:
    2,152
    Likes Received:
    1,546
    Use Xcode 8 not Xcode 9 for the time being. We will have updates to conform to new requirements of Xcode 9 soon.
     
  7. shayeb

    shayeb Boxer

    Joined:
    Apr 2, 2017
    Messages:
    37
    Likes Received:
    0
    but is it gonna work on ios 11.0.3 devices?
     
  8. shayeb

    shayeb Boxer

    Joined:
    Apr 2, 2017
    Messages:
    37
    Likes Received:
    0
     

    Attached Files:

  9. AaroArts

    AaroArts Miniboss Boxer

    Joined:
    Jun 22, 2016
    Messages:
    1,546
    Likes Received:
    826
    Use Xcode 8.2 or 8.3 to upload a build to iTunes Connect.

    It will still work with iOS 11, assuming it works on iOS 10.
     
  10. shayeb

    shayeb Boxer

    Joined:
    Apr 2, 2017
    Messages:
    37
    Likes Received:
    0
    it doesnt support ios 11
     
  11. shayeb

    shayeb Boxer

    Joined:
    Apr 2, 2017
    Messages:
    37
    Likes Received:
    0
    when i sbuildbox gonna be update it to support ios 11.0.3 so i guess ill just wait till you guys update so i can submit my game
     
  12. noahcdesign

    noahcdesign Avid Boxer

    Joined:
    Oct 10, 2017
    Messages:
    104
    Likes Received:
    44
    I use xcode 8 and my apps work fine on iOS 11?
     
  13. shayeb

    shayeb Boxer

    Joined:
    Apr 2, 2017
    Messages:
    37
    Likes Received:
    0
    do you use xcode 8 or 8.3?
     
  14. noahcdesign

    noahcdesign Avid Boxer

    Joined:
    Oct 10, 2017
    Messages:
    104
    Likes Received:
    44
    8
     
  15. shayeb

    shayeb Boxer

    Joined:
    Apr 2, 2017
    Messages:
    37
    Likes Received:
    0
    when i connect my phone to xcode to test my game it doesn't work because my iphone 6 is running ios 11.0.3 so should i just ignore it?
     
  16. AaroArts

    AaroArts Miniboss Boxer

    Joined:
    Jun 22, 2016
    Messages:
    1,546
    Likes Received:
    826
    You can test it in Xcode 9 and on a real device using iOS 11+, but only upload a build from Xcode 8 to 8.3 to iTunes Connect as BuildBox doesn’t support iOS 11 at the moment.

    It doesn’t mean it won’t work on iOS 11.

    But if you really want to test it on iOS 11 on a real device from Xcode 8, you can copy the 11.0 Device Support Folder from Xcode 9 to Xcode 8.

    Location:
    Xcode/Contents/Developer/Platforms/iPhoneOS.platform/SeviceSupport/
     
    noahcdesign likes this.
  17. shayeb

    shayeb Boxer

    Joined:
    Apr 2, 2017
    Messages:
    37
    Likes Received:
    0




    ok so im using xcode 8.3 but i still get this error check the image please
     

    Attached Files:

  18. M9 Games

    M9 Games Boxer

    Joined:
    Oct 28, 2017
    Messages:
    18
    Likes Received:
    11
    You just need to iterate your build number just below the version number to something greater than 1 in xcode
     
  19. adrogdesigns

    adrogdesigns Avid Boxer

    Joined:
    Dec 5, 2016
    Messages:
    318
    Likes Received:
    233
    you need to test on a device with iOS 10 if your using Xcode 8, if you submit to iTunes connect it will work on iOS 11
    or as AaroArts said you can copy the 11.0 Device Support Folder from Xcode 9 to Xcode 8. Then you can test on your device.
     
  20. AaroArts

    AaroArts Miniboss Boxer

    Joined:
    Jun 22, 2016
    Messages:
    1,546
    Likes Received:
    826
    You’ve already uploaded a build 1.0.
    You need to upload a new build 1.1
     

Share This Page