"invalid Build" On Itunes Connect!.

Discussion in 'Technical Discussion' started by Esterion, Oct 13, 2017.

  1. Esterion

    Esterion Boxer

    Joined:
    Sep 16, 2017
    Messages:
    42
    Likes Received:
    12
    Hello! whenever I send a build on iTunes Connect it always say it is invalid. how can I fix this? thanks!
     
  2. AaroArts

    AaroArts Miniboss Boxer

    Joined:
    Jun 22, 2016
    Messages:
    1,532
    Likes Received:
    816
    How are you sending your build to iTunes Connect?
    Does the Xcode Project Build number and Bundle IDs match those in your iTunes Connect app that you created?
     
    Christoph likes this.
  3. Esterion

    Esterion Boxer

    Joined:
    Sep 16, 2017
    Messages:
    42
    Likes Received:
    12
    Hello! thanks for replying I now have found the problem and it says
    my build is invalid and I checked my mail this is what it says.

    Missing Info.plist value - A value for the Info.plist key 'CFBundleIconName' is missing in the bundle 'com.Esterion.Cubist2'. Apps built with iOS 11 or later SDK must supply app icons in an asset catalog and must also provide a value for this Info.plist key. For more information see http://help.apple.com/xcode/mac/current/#/dev10510b1f7.

    can you help me with this one?
     
  4. AaroArts

    AaroArts Miniboss Boxer

    Joined:
    Jun 22, 2016
    Messages:
    1,532
    Likes Received:
    816
    You need to use Xcode 8.3, not xCode 9.
    Upload from Xcode 8.3.3 or 8.3.2 and it'll work fine.
     

Share This Page