ERROR ITMS-90096 Issue With Uploading Game To iTunes

Discussion in 'Buildbox General Discussion' started by dusan20002, Apr 18, 2016.

  1. dusan20002

    dusan20002 Avid Boxer

    Joined:
    Dec 7, 2015
    Messages:
    136
    Likes Received:
    55
    We was trying today to upload updated version of our game, its made in BuildBox 1.3.6, and we was getting this kind of warning from Apple.

    Screen Shot 2016-04-18 at 8.25.19 PM.png

    After checking Info.plist we found all of images.
    Screen Shot 2016-04-18 at 8.28.19 PM.png

    It was something strange with uploading process, at one time it was written Connection Lost Trying To Reconnect With iTunes Connect Servers.
     
  2. Andy

    Andy Miniboss Boxer

    Joined:
    Sep 24, 2015
    Messages:
    2,152
    Likes Received:
    1,545
    What version of Xcode are you using? With 1.3.6 it's preferable to use Xcode 7 (latest version) and iOS 9 SDK. If you are going to use iOS 8 SDK then you should use Xcode 6 (latest).
     
  3. dusan20002

    dusan20002 Avid Boxer

    Joined:
    Dec 7, 2015
    Messages:
    136
    Likes Received:
    55
    Hi @Andy,
    We using Version 7.3 (7D175), even if we start submitting App with 9.0 SDK or 9.3 SDK it coming up same message.
    During process it come this message also, which we never seen before in submitting process.
    Screen Shot 2016-04-19 at 7.06.35 AM.png

    We will try to make it somehow, but funny is that we have updated and submitted some of our games three days ago without any issue.

    Thank you for your time.
     
  4. Andy

    Andy Miniboss Boxer

    Joined:
    Sep 24, 2015
    Messages:
    2,152
    Likes Received:
    1,545
    Hmmm... interesting. It's possible Apple servers are having some troubles, but a quick Google search does not reveal anyone else complaining. I'd try again over the next couple days and see if it sorts out. In the meantime maybe someone else can confirm if they are having any issues or not. Keep us posted for sure on the results and I will keep my eyes peeled for any other information.
     
  5. dusan20002

    dusan20002 Avid Boxer

    Joined:
    Dec 7, 2015
    Messages:
    136
    Likes Received:
    55
    We was trying all day to find solution for it.
    Google it, but did not find solutions.

    We was checking image assets in Resource folder with other our games and all of the are the same, Portrait Mode of screen.
    Even if we migrate image to Assets catalog under App Icons and Launch Images image it happen again.

    What we was doing is try to export again from BB1.3.5 and try to upload, and its was successful.
    One thing from BB135 export is giving less Launch images then BB136 ( BB135 8 Launch images, BB136 11 Launch images ).

    We also hope and think that was some Apple serves issue, as later on we was trying to update game made by BB2 - Version 5, and everything went smoothly.

    We will post of we still find something.

    Thank you @Andy for your assistance and time that you have spend on looking for answer.
     
  6. Andy

    Andy Miniboss Boxer

    Joined:
    Sep 24, 2015
    Messages:
    2,152
    Likes Received:
    1,545
    We had to completely redo the launch images with the Xcode 7 / iOS 9 SDK update in Buildbox 1.3.6 (and 2.0). So that is why you are seeing the difference. BB 1.3.6 and BB 2.x *SHOULD* behave identically regarding launch images. Thanks for the additional info.
     
  7. dusan20002

    dusan20002 Avid Boxer

    Joined:
    Dec 7, 2015
    Messages:
    136
    Likes Received:
    55
    Thank you one more time for resourceful info @Andy.
     
  8. dusan20002

    dusan20002 Avid Boxer

    Joined:
    Dec 7, 2015
    Messages:
    136
    Likes Received:
    55
    An Update.
    We have submitted App to iTunes, but we was using Application Loader, as still we could not upload through Xcode Archive.

    We Export .ipa from Xcode and using Application Loader upload game to iTunes.
    What was surprising is that in just 4 hours our game was already In Review.

    Thank you @Andy for support.
     
  9. Andy

    Andy Miniboss Boxer

    Joined:
    Sep 24, 2015
    Messages:
    2,152
    Likes Received:
    1,545
    Wow, good news. :)

    I have heard in the past at times that on occasion Xcode didn't worked and Application Loader did (or vice versa). Not sure why though, but it must be issue on Apples end I would guess is most likely.
     
    Sean Buildbox and dusan20002 like this.
  10. MethGames

    MethGames Boxer

    Joined:
    Sep 25, 2015
    Messages:
    56
    Likes Received:
    18
    Please Help me. From 2 days i try to upload my game to appstore and i have the same problem like dusan20002.
    I using BB 1.3.6 windows. Xcode version is the last and i have try to set ios 9.3 / 8.4 / 8.0 on the general tab. I have try to upload with Xcode uploader and with itunes loader and always the same problem. Please help me to solve this problem because i'm going crazy...!!!

    It's possible download a prev version BB1.3.5 for trying to export with it?
     
    Last edited: May 27, 2016
  11. dusan20002

    dusan20002 Avid Boxer

    Joined:
    Dec 7, 2015
    Messages:
    136
    Likes Received:
    55
    Hi @MethGames try to export your game from Xcode uploader to .ipa file on your desktop and then try to upload .ipa with Application Loader to iTunes Connect.
    This always work for us if we facing some issue in Xcode uploader.

    Go to Project -> Archive -> Export -> thick Save for IOS App Store Deployment click Next -> Choose your Export destination click Export -> Launch Application Loader -> Choose exported .ipa file and upload your game to iTunes connect.

    Hope we could assist here.
     
  12. MethGames

    MethGames Boxer

    Joined:
    Sep 25, 2015
    Messages:
    56
    Likes Received:
    18
    i have try my friend but always the same error. Now i hope andy reply me, i need to try to install BB1.3.6 on MAc and export from mac. Bu unfortunally i dont see any link for downloading BB1.3.6 for mac.
     
  13. MethGames

    MethGames Boxer

    Joined:
    Sep 25, 2015
    Messages:
    56
    Likes Received:
    18
    Andy please can help me?
    i have contact the support but no one reply a solution..!!!!
     
  14. Andy

    Andy Miniboss Boxer

    Joined:
    Sep 24, 2015
    Messages:
    2,152
    Likes Received:
    1,545
    It is a holiday weekend in the US, support is back on Tuesday. I believe your issue is that you are editing Xcode project. You do not need to make any changes after export if you are using Xcode 7. You DO NOT want to set the deployment target to 9.0, even if it worked you would only be able to run your game on iOS 9 devices.
     
  15. MethGames

    MethGames Boxer

    Joined:
    Sep 25, 2015
    Messages:
    56
    Likes Received:
    18
    ok i think i'm not explain really well. I dont have change nothing on Xcode. i dont have change the SDK, they are setting in default 9.3 last version. I have change only the target version the first time but then i have export the project multiple time with default settings, and dsn't work again. The problem are in BB1.3.6 exportation file project.
     
  16. trudnai

    trudnai Miniboss Boxer

    Joined:
    Sep 25, 2015
    Messages:
    1,234
    Likes Received:
    696
    Sounds like you are not moving the previous export folder to trash before exporting your game again from BB.
     
  17. MethGames

    MethGames Boxer

    Joined:
    Sep 25, 2015
    Messages:
    56
    Likes Received:
    18
    ok guys. i have partially solved the problem. In my case the problem was the png compress setting on Xcode. If i try to publish with it set in "YES" i get the error.
    Another problem are the Heyzap mediation and target deployment.
    If i need to use the mediation heyzap, the minimum target deployment are 7.1. But if i try to use 7.1 or 8 target, i get many xcode errors. So, at moment i have publish the game without mediation integration and during this week i will contact my friend "Code Expert" for try to solve this problem.

    Stay tuned.
     
  18. qbeesoft

    qbeesoft Avid Boxer

    Joined:
    Dec 17, 2015
    Messages:
    119
    Likes Received:
    23
    hey man!
    I got into the same error and it is driving me nuts. What did you do to solve this?
     
  19. Benfont

    Benfont Avid Boxer

    Joined:
    Sep 27, 2016
    Messages:
    277
    Likes Received:
    277
    Good morning,

    I am having the exact same issue and I don't know how to fix it, I have tried everything so far.
    I am using BB 2 // xcode 7.3.1 and iOS target 9.0

    I checked the resources inside the folder of my project and I do have that splash screen for the iPhone 5 resolution,

    Can I please get a hand here?

    Many thanks,
    BR

    UPDATE: I made it work by setting up the iOS target to 8.0 / thanks anyway for the help
     
    Last edited: Oct 25, 2016

Share This Page