Enemy Defeated Animation not working

Discussion in 'Technical Discussion' started by ArmanEker, May 7, 2016.

  1. ArmanEker

    ArmanEker Boxer

    Joined:
    Mar 26, 2016
    Messages:
    19
    Likes Received:
    0
    Hi All,
    I have a enemy which when colliding with my character destroys the character. I added a defeated animation to the enemy but somehow it is not displayed. When the character hits the enemy the game ends and no animation. When I add the same animation to the character it is displayed. What am I missing?

    Thanks.
     
  2. heathclose

    heathclose Miniboss Boxer

    Joined:
    Jan 28, 2016
    Messages:
    1,810
    Likes Received:
    1,025
    does the enemy stay on the screen or just disappear?

    also, the first place I would look when it comes to funkiness with game over is the game over delay which you can find by selecting your character to the far upper left and on the right, scroll down for these options...
    Screen Shot 2016-05-07 at 7.57.03 AM.png
    the game over delay is an amount in seconds that the game lets happen between character death and the appearance of your game over ui

    I'm not sure if this is any help, but it might be a start
     
  3. ArmanEker

    ArmanEker Boxer

    Joined:
    Mar 26, 2016
    Messages:
    19
    Likes Received:
    0
    Hi,
    I already have these options set as you mentioned. When the character is destroyed it plays the animation but when the enemy is destroy it doesn't. In my game the character and object (enemy) collide and both should be destroyed and both defeat animation should be played. But unfortunately just the character defeat animation is played. I set the damage of character to 1 and also set health of enemy to 1 but it didn't helped. The enemy is set as following: Collision Type: Collide. Destroy Type: Destroy All.

    Any ideas?
     
  4. heathclose

    heathclose Miniboss Boxer

    Joined:
    Jan 28, 2016
    Messages:
    1,810
    Likes Received:
    1,025
    just out of sheer morbid curiosity... set destroy to destroy character and see if the animation plays
     
    ArmanEker likes this.
  5. viking

    viking Avid Boxer

    Joined:
    Sep 25, 2015
    Messages:
    152
    Likes Received:
    72
    hi
    may be it s because you dont actualy kill the ennemi but just collide with it
    you need tu use invinsible or strike
    but you wont die ;)
     
  6. ArmanEker

    ArmanEker Boxer

    Joined:
    Mar 26, 2016
    Messages:
    19
    Likes Received:
    0
    Your curiosity solved my problem! :) I thougt I did try it but it seems I haven't tested it properly!

    Thank you very much.

    PS: character damage has to be set to 1.
     
  7. cantinuelo

    cantinuelo Boxer

    Joined:
    Mar 3, 2016
    Messages:
    18
    Likes Received:
    1
    Hi heathclose , im creating a game like Color Switch ( to learn how BB works) If i change the Game Over Delay to more than 0, charater defeated animation dont apears. If i turn it back to 0 , it appears. Why?
    I would like to have a Game Over Delay of 2 , but then the defeated animationd dont shows. Any help of what can i do? thanks
     
  8. heathclose

    heathclose Miniboss Boxer

    Joined:
    Jan 28, 2016
    Messages:
    1,810
    Likes Received:
    1,025
    I don't know... that's backwards to what the problem usually is... what do you have set for frames and time in the animation editor of your defeat animation?
     
  9. cantinuelo

    cantinuelo Boxer

    Joined:
    Mar 3, 2016
    Messages:
    18
    Likes Received:
    1
    Hi, animation is set to 8 Duration (frames) and 1 to Animation speed.
    Also now there is another error plroblem. When i test the game on BB the checkpoint counter works ok. I have it for test , quantity 300 checkpoint continues. Now i lower it to 25, export to Android, install on my phone. But on my phone , the counter keep on 300. Why if i already change it long before exporting. I check and re check, re export , close and restart BB, but nothing fix it.
    Do BB1 recently have any sort of update that is making it giving me that errors?
    Because a less than month ago i can change checkpoint continues quantities and no problems on my phone.
     
  10. heathclose

    heathclose Miniboss Boxer

    Joined:
    Jan 28, 2016
    Messages:
    1,810
    Likes Received:
    1,025
    yah I would take this to the bug section of the forums and send your bbdoc into support@buildbox.com so they can see both errors...
     
  11. cantinuelo

    cantinuelo Boxer

    Joined:
    Mar 3, 2016
    Messages:
    18
    Likes Received:
    1
    ok, i would do that. Thanks heathclose.
     
  12. cantinuelo

    cantinuelo Boxer

    Joined:
    Mar 3, 2016
    Messages:
    18
    Likes Received:
    1
    i installed the game in galaxy s6 and the change of CheckPoints quantity from 300 to 15 is working. But not on my Note 5. I change the version to 2.5(it was 2)in BuildBox setting , export, mount on my Note 5, but still showing 300 Checkpoints. i restart my phone, run clean master, but still the same. Do i have to erase some sort of BB cache on my phone, or maybe is a bug with the Galaxy Note 5 ? hummm.
     
  13. INKY

    INKY Avid Boxer

    Joined:
    May 13, 2016
    Messages:
    161
    Likes Received:
    67
    I just found for me...that in no case can I get the defeated animation of my character to work.

    Support here I come !!

    Correction. I just deleted the instance and dropped it back in. Works fine now.
     
  14. nayamamarshe

    nayamamarshe Avid Boxer

    Joined:
    Feb 21, 2016
    Messages:
    237
    Likes Received:
    64
    I am having the same problem @heathclose I think its the problem with the new update. When I set GOD>0 the defeated animation isn't played.
     
  15. Cyberlab games

    Cyberlab games Boxer

    Joined:
    Jun 5, 2016
    Messages:
    42
    Likes Received:
    4
    i got the missile to explode when it hit a enemy but it stop working why
     

Share This Page