Connection Mode Is Causing Render In Wrong Order

Discussion in 'How Can I...?' started by sir_freddy, Nov 14, 2017.

  1. sir_freddy

    sir_freddy Boxer

    Joined:
    Apr 24, 2017
    Messages:
    39
    Likes Received:
    10
    Hello,
    I am pretty sure I am not the only one with this problem:
    Whenever I connect multiple objects with the connection mode and start the game they render in the wrong order. Objects that are supposed to be behind another object appear suddenly in front. Switching the connection does not really help.
    Thanks for any replies! :D
    upload_2017-11-15_2-38-47.png
    [​IMG]
    upload_2017-11-15_2-39-16.png
     

    Attached Files:

  2. miika

    miika Boxer

    Joined:
    Feb 1, 2016
    Messages:
    26
    Likes Received:
    1
    If this kind of a bug exists, I would contact Buildbox via support@buildbox.com. Would help others a lot if they were aware of this.
     
  3. sir_freddy

    sir_freddy Boxer

    Joined:
    Apr 24, 2017
    Messages:
    39
    Likes Received:
    10
    It has always been like this for me but it was not really a problem till I started designing an isometric game. I think the problem is that BB handles 2 connected objects as one and spawns them at the same moment which causes the wrong order.
     
  4. Christoph

    Christoph Miniboss Boxer

    Joined:
    Oct 4, 2015
    Messages:
    2,808
    Likes Received:
    2,310
    All connected objects appear at the same 'level' as the original object. Yes, that always was like that. :(
     

Share This Page