Buildbox 2.3.7

Discussion in 'Official Announcements' started by NikRudenko, Nov 1, 2018.

  1. EminUlus

    EminUlus Boxer

    Joined:
    Jan 2, 2018
    Messages:
    14
    Likes Received:
    15
    Hi @NikRudenko ,
    Advanced Move ----- > Event : Switch A or B Button activate on release not working.
     
  2. AaroArts

    AaroArts Miniboss Boxer

    Joined:
    Jun 22, 2016
    Messages:
    1,515
    Likes Received:
    794
    I'm not sure how bugs are being logged here anymore, but I found another issue in 2.3.7.
    Block Touch Through does't work if you use two fingers.
    Block Touch Through is ignored if you tap with one finger, then tap with a second, or simply tap the button with two fingers.

    Support mentioned an update to 2.3.X was being worked on this coming week, is this still the case?
    Looking forward to it :) Keep up the good work.
     
  3. vikash

    vikash Boxer

    Joined:
    Jun 20, 2017
    Messages:
    61
    Likes Received:
    20
    Hey, Module error everytime. Cant export my game. Asked to support but they are not giving me solution. They told me to delete the files from library but that doesn't work for me.
    What should I do?
     
  4. spicedbeangames

    spicedbeangames Miniboss Boxer

    Joined:
    Mar 31, 2016
    Messages:
    1,187
    Likes Received:
    503
    wait for all the modules to download?
     
  5. vikash

    vikash Boxer

    Joined:
    Jun 20, 2017
    Messages:
    61
    Likes Received:
    20
    My Problem is when I am opening software & start working over any templates...they have started download module and suddenly saying cant download modules...please contact support...
    I have contacted but not getting right solutions.
    How to manage it?
     
  6. Christoph

    Christoph Miniboss Boxer

    Joined:
    Oct 4, 2015
    Messages:
    2,808
    Likes Received:
    2,305
    This seems to be a time out. Your connection is probably too bad. Are you on wifi? If yes, try to use ethernet connection to download the modules. I had the same problem and that solved it.
     
  7. vikash

    vikash Boxer

    Joined:
    Jun 20, 2017
    Messages:
    61
    Likes Received:
    20
    No! It was a back end issue. Now fixed by support team. :)
     
  8. nyamuk91

    nyamuk91 Boxer

    Joined:
    Aug 15, 2018
    Messages:
    92
    Likes Received:
    17
    Created a thread but no one replies. So trying my luck here:

    I found a weird behavior in BB 2.3.7 when I turned on "Destroy All" on an object that has its image offset by few hundreds of pixels like this. This is the object instance settings. It works as expected in this settings. In other words, it rotates based on the center of the object. However, when I turn on "Destroy All" on the object instance, this happened. Seems like, it rotates based on the center of the image, not the object. Is this a bug? Or is this expected behavior?
     
  9. AaroArts

    AaroArts Miniboss Boxer

    Joined:
    Jun 22, 2016
    Messages:
    1,515
    Likes Received:
    794
    This is not a bug. I believe it’s acting as it should.
    You’re rotating the sprite, not the objects space if that makes sense.
     
  10. nyamuk91

    nyamuk91 Boxer

    Joined:
    Aug 15, 2018
    Messages:
    92
    Likes Received:
    17
    But why it didn't behave like that when it is set to "No Destroy"? And if it's a bug with "No Destroy" instead, why it is made as a mechanic for "World Jumper" template? o_O
     
  11. AaroArts

    AaroArts Miniboss Boxer

    Joined:
    Jun 22, 2016
    Messages:
    1,515
    Likes Received:
    794
    Oh, sorry. The gif's didn't load when I looked the first time.
    Is your sprite definitely positioned correctly in the Animation Frame?
    I would check that first before assuming it's a bug. I would also email a BBDoc to Support demonstrating this if you're sure everything is set up correctly.
    Just bare in mind that if you do set this Object to Destroy All, it will even destroy the other Objects in the scene anyway.
     
  12. nyamuk91

    nyamuk91 Boxer

    Joined:
    Aug 15, 2018
    Messages:
    92
    Likes Received:
    17
    Not sure what you meant by this, but if the position is incorrect, shouldn't it behave the same regardless of whether it's "No Destroy" or "Destroy All"? Also, where do I submit bug reports? Is it at "support@buildbox.com" or do they have a specific email for that?
     
  13. Josh (Nology Games)

    Josh (Nology Games) Head Moderator Staff Member

    Joined:
    Nov 27, 2017
    Messages:
    438
    Likes Received:
    136
  14. Coldwilson

    Coldwilson Boxer

    Joined:
    Dec 18, 2017
    Messages:
    73
    Likes Received:
    30
    Decided to take the plunge and upgrade to 2.3.7 today as I was getting daily cannot connect to server issues which then loses the game, it's been said before but having to connect online to save a local file is a PITA. Thought this version might have fixed it.

    Disappointed to see that the ability to deselect and item is not working now on the Mac. i.e. if I've selected multiple items then can deselect one item by holding command key and clicking the item. I've tried many other combos to see it had changed. Nope. I use this feature many times a day.

    So now gone back to 2.3.6

    Please fix
     
  15. AaroArts

    AaroArts Miniboss Boxer

    Joined:
    Jun 22, 2016
    Messages:
    1,515
    Likes Received:
    794
    I would try reinstalling 2.3.7 because this feature is working for me. Worth a shot.
     
  16. Coldwilson

    Coldwilson Boxer

    Joined:
    Dec 18, 2017
    Messages:
    73
    Likes Received:
    30
    Thanks AaroArts, that's encouraging to hear. I will give it another go, perhaps a machine restart will help. I should have tried it with another project to eliminate other things I guess. I'll update when I get to it.
     
  17. volcank

    volcank Serious Boxer

    Joined:
    Oct 8, 2015
    Messages:
    671
    Likes Received:
    301
    Hi so I am trying to make a new game here and there is a big bug in trail functionality. I also remember Christoph had been banned for reporting these kinds of bugs in public and truly don't understand why since we the users are here to talk about the bugs so they can be fixed. So I just wanted to mention this here. Anyway After sometime like 4-5 scenes it starts to look weird like pixelized and gets worse and worse and at one time it even got dissappeared! This really makes the game look unproffesional and can not publish my game this way. When will this get fixed cause this is a basic thing and I am about to publish my game soon for all apstores. Will there be a 2.3.8 soon?
     
    Collin Wade Thiessen likes this.
  18. Josh (Nology Games)

    Josh (Nology Games) Head Moderator Staff Member

    Joined:
    Nov 27, 2017
    Messages:
    438
    Likes Received:
    136
    @volcank he was not banned for reporting bugs, we encourage everyone to report things so that we can fix it. It's also good to send it to support@buildbox.com as they will see it as well.
     
    volcank likes this.
  19. volcank

    volcank Serious Boxer

    Joined:
    Oct 8, 2015
    Messages:
    671
    Likes Received:
    301
    Ok that's what I thought it was! Ok sent the issue to Support! Thanks.
     
  20. Xoctrebla

    Xoctrebla Avid Boxer

    Joined:
    Mar 19, 2017
    Messages:
    144
    Likes Received:
    77
    Don't use Trails.... Use Particles. I see this bug all the time when playing games.
     
    Collin Wade Thiessen and volcank like this.

Share This Page