Buildbbox 3.0 Beta 1 Bugs Report Thread

Discussion in 'Buildbox 3.0' started by wesam_badr, Jul 26, 2018.

  1. wayne_martell

    wayne_martell Avid Boxer

    Joined:
    Sep 25, 2015
    Messages:
    270
    Likes Received:
    84
    P.S The enemy group does work so all good so far !
     
  2. AndyG

    AndyG Miniboss Boxer

    Joined:
    Sep 25, 2015
    Messages:
    1,099
    Likes Received:
    909
    Where is the Enemy Group coming from? Is that a Node!!
     
  3. wayne_martell

    wayne_martell Avid Boxer

    Joined:
    Sep 25, 2015
    Messages:
    270
    Likes Received:
    84
    When you're in the 3D world select the object over the top right there will be a collision Group change it from none to enemy and do the same for "if collide" node.
     
    AndyG likes this.
  4. AndyG

    AndyG Miniboss Boxer

    Joined:
    Sep 25, 2015
    Messages:
    1,099
    Likes Received:
    909
    Ah right I got it. Thanks. Thats excellent :)
     
  5. thatguyminib

    thatguyminib Serious Boxer

    Joined:
    Jul 1, 2017
    Messages:
    553
    Likes Received:
    305
    This should not be happening. You can't give people a 3d engine and not expect them to not want to use high quality models. Then again I am using a spaceship from Kenny assets that is not complex at all and it still makes the engine crash. Hopefully this will get fixed soon.
     
    NikRudenko likes this.
  6. Buildbox

    Buildbox Administrator

    Joined:
    Sep 15, 2015
    Messages:
    101
    Likes Received:
    199
    Remember, we are in beta!
     
    AndyG likes this.
  7. NikRudenko

    NikRudenko Administrator Staff Member

    Joined:
    Sep 25, 2015
    Messages:
    176
    Likes Received:
    488
    Yep :) Working on it
     
    thatguyminib likes this.
  8. steves

    steves Boxer

    Joined:
    Mar 29, 2018
    Messages:
    12
    Likes Received:
    2
    My issue is everything seems to work, except when I go to preview, then it just crashes, shuts down buildbox.
    anyone else have this happen?
     
    Titus likes this.
  9. Titus

    Titus Boxer

    Joined:
    Jun 10, 2018
    Messages:
    8
    Likes Received:
    2
    This happens to me. When i run it with my intel graphics card (default embedded) the preview crashed buildbox. When I switch to the Nvidia card, then it allows preview, but the mindmap and other buttons do not work. I am using Intel 5500 and Nvidia 850M ,
     

    Attached Files:

  10. Rebel Studios

    Rebel Studios Avid Boxer

    Joined:
    Sep 25, 2015
    Messages:
    456
    Likes Received:
    280
    Same here too
     
  11. wesam_badr

    wesam_badr Miniboss Boxer

    Joined:
    Oct 10, 2015
    Messages:
    1,062
    Likes Received:
    478
    Yes if you see my post its the same happening to me, I think its happening to lot of boxers. it's a memory issue.
     
  12. AndyG

    AndyG Miniboss Boxer

    Joined:
    Sep 25, 2015
    Messages:
    1,099
    Likes Received:
    909
    Nik posted a video earlier in this thread.
     
    Rebel Studios likes this.
  13. jcalle

    jcalle Miniboss Boxer

    Joined:
    Sep 25, 2015
    Messages:
    1,110
    Likes Received:
    481
    This error I already reported from the BB3 Alpha 2 version, to the support by mail and in the forum, and I still do not have news.
    Apparently, BB3 uses OpenGL, Direct3D or other drivers for 3D, which does not work properly on some models of graphics card.
    I do not know if the BB team is going to solve it, since in computers with mid-range graphics cards it also fails.
     
  14. steves

    steves Boxer

    Joined:
    Mar 29, 2018
    Messages:
    12
    Likes Received:
    2
    ok... just wanted to make sure it was just not me...
    i assume an update will fix the issue going forward.


     
  15. steves

    steves Boxer

    Joined:
    Mar 29, 2018
    Messages:
    12
    Likes Received:
    2
    Here was the fix I used on my Toshiba Tecra.

    Disable the Intel Video card.
    The Nvidia Becomes the new card
    reboot the machine
    Now you should be able to Run the Preview, I can no.


     
  16. Vlad-NY

    Vlad-NY Boxer

    Joined:
    Jul 21, 2018
    Messages:
    39
    Likes Received:
    8
    Hey @steves thanks for your help.

    I manage to fix my beta version as follows:
    1. Right click and select Nvidia Control Panel
    2. From there click on Manage 3D settings
    3. From Global Settings tab select High-Peformance NVIDIA processor
    4. Tap on Program Settings tab
    5. Tap on Add button -> Browse (from Add tab) and add buildbox.exe from installed location
    6. Tap on Add selected program
    7. Tap on Apply button
    By following the above steps I manage to fix the crash that i had while trying to preview the game.

    I hope this helps others with NVIDIA chipset

    Best regards
    Vlad
     

    Attached Files:

  17. jaydenf95

    jaydenf95 Boxer

    Joined:
    Jul 19, 2018
    Messages:
    11
    Likes Received:
    0
    Does anyone know how to add sound effects, im trying to get a "slingshot" to collect points which works, but I can't seem to add sound effects to points???
     
  18. Devops

    Devops Boxer

    Joined:
    Aug 1, 2018
    Messages:
    21
    Likes Received:
    0
    Hi, the collision for points is not working correctly for demo FLY;
    I tried to add a 'if collision' on the POINT, then remove this OBJECT(the point) and its not removing.
     
  19. wayne_martell

    wayne_martell Avid Boxer

    Joined:
    Sep 25, 2015
    Messages:
    270
    Likes Received:
    84
    Go to the the node editor then Content you'll find a sound node there but then you need to hook it up to a Actions node of some kind !
     
    Last edited: Aug 2, 2018
  20. jaydenf95

    jaydenf95 Boxer

    Joined:
    Jul 19, 2018
    Messages:
    11
    Likes Received:
    0
    I did that, i had "start" - "if collide" - "sound" so essentially if that object collides with my slingshot it should play the sound? Well that's my understanding of it anyway, but for some reason it doesn't work.
     

Share This Page