Build Failiures On Xcode, Won't Export Or Build To Device.

Discussion in 'Technical Discussion' started by Angus Glassford, Nov 24, 2020.

  1. Angus Glassford

    Angus Glassford Boxer

    Joined:
    Nov 24, 2020
    Messages:
    4
    Likes Received:
    0
    I have been trying to export my game via Xcode however it keeps throwing the following errors. I was wondering if anyone has seen this before and if so, what was the fix? Thanks

    Undefined symbol: _VTDecompressionSessionDecodeFrameWithOutputHandler

    Undefined symbol: _kVTDecompressionPropertyKey_PixelBufferPool

    Undefined symbol: _kVTDecompressionPropertyKey_PixelBufferPoolIsShared

    Undefined symbol: _kVTDecompressionPropertyKey_OutputPoolRequestedMinimumBufferCount

    Undefined symbol: _VTSessionSetProperty​
     
  2. Sean Buildbox

    Sean Buildbox Administrator Staff Member

    Joined:
    Sep 24, 2015
    Messages:
    847
    Likes Received:
    1,020
    Can you screenshot the xCode screen? Assuming you have an Apple Developer account already correct?
     
  3. Angus Glassford

    Angus Glassford Boxer

    Joined:
    Nov 24, 2020
    Messages:
    4
    Likes Received:
    0
    Hi Sean,
    Please see attached my XCode screenshot. I have used buildbox for another game and then exported to IOS and built it and that worked fine so not sure what is diferent this time. They were only a few days from each other.

    On another note, I tried to update buildbox on my computer and I keep getting the system limit reached error despite only having it on two computers, but a few different versions. I don 't need to use it on my windows PC any more.
    Thanks
    Angus
    upload_2020-11-25_5-33-53.png
     
  4. Angus Glassford

    Angus Glassford Boxer

    Joined:
    Nov 24, 2020
    Messages:
    4
    Likes Received:
    0
    Hi @Sean Buildbox I would really appreciate it if you would be able to look into this and my licensing issue on buildbox.
    Thanks
    Angus
     
  5. DariusGuerrero

    DariusGuerrero Moderator Staff Member

    Joined:
    Dec 22, 2016
    Messages:
    461
    Likes Received:
    383
    try exporting with buildbox again. this happened to me once or twice and my theory was that i need take like an extra minute before opening it with code. might be wrong though. it's just a theory
     
  6. Angus Glassford

    Angus Glassford Boxer

    Joined:
    Nov 24, 2020
    Messages:
    4
    Likes Received:
    0
    Hi,
    Thank you, I have tried to do that a few times but still nothing. I hadn't realised but my subscription was on an old card and wasn't actually being paid. I then tried to upgrade my account but there was an error with the payment system so I had to do it on another account. As my project is in BB2, I need to change my license to BB2 from BB3. Also, I can't login to my new account on my computer (I have tried deleting the com.buildbox.eightcell etc.) but that didn't change anything. I am getting quite frustrated with the support as they are not very good at replying to emails to fix a (seemingly simple) Issue.

    Thanks
    Angus
     
  7. Josh (Nology Games)

    Josh (Nology Games) Community Manager

    Joined:
    Nov 27, 2017
    Messages:
    869
    Likes Received:
    268
    Hello, have you heard from support yet?
     

Share This Page