Applovin Warnings Inside Xcode

Discussion in 'Technical Discussion' started by volcank, Nov 16, 2016.

  1. volcank

    volcank Serious Boxer

    Joined:
    Oct 8, 2015
    Messages:
    786
    Likes Received:
    389
    Hi,
    When I try to use Applovin inside my game and import my project into Xcode it gives like 81 errors of the following error.

    ld: warning: object file (libs/ads/PTAdAppLovin/sdk/libAppLovinSDK.a(ALHtmlAdView.o)) was built for newer iOS version (6.1) than being linked (6.0)

    The game works fine and it shows applovin but sometimes ads lag a little not as fast as admob or chartboost. Also the applovin ads seems to force quit my game. Does anyone know the reason for this??

    Thank You
     
  2. Christoph

    Christoph Miniboss Boxer

    Joined:
    Oct 4, 2015
    Messages:
    2,807
    Likes Received:
    2,309
    Yeah, you are building for ios 6 and above. Just change this to ios 8 and above and it should disappear. There is no reason why you should build for ios 6 or 7. These OS's run only on very old devices on which your game most probably doesn't work anyway. Also, I remember, one of the steps of Heyzap Mediation integration is to use ios 7.0 or later. SDK 9 is not compatible with ios 6. But as I said, to be sure all other SDKs run for sure without any problems change it to ios 8.

    http://buildbox.com/forum/index.php?threads/ios-heyzap-mediation-tutorial.3565/ --> step 12 of the Xcode part.
     
  3. volcank

    volcank Serious Boxer

    Joined:
    Oct 8, 2015
    Messages:
    786
    Likes Received:
    389
    I guess we change it inside Xcode right where it says deployment targetç I change it and errors don't go! Btw. Which ad network would you prefer applovin or chartboost?? I am already using Admob but would like to add one of these for extra flavor :)
     
    Last edited: Nov 16, 2016
  4. Christoph

    Christoph Miniboss Boxer

    Joined:
    Oct 4, 2015
    Messages:
    2,807
    Likes Received:
    2,309
    Yes, that's where you change it. I don't have any errors with applovin. I don't use Chartboost anymore as it doesn't give me any review at all when using it through mediation. The only thing I can think of is that you have an applovin SDK which is not compatible with the Heyzap 9.x SDK(?)
     
    volcank likes this.
  5. volcank

    volcank Serious Boxer

    Joined:
    Oct 8, 2015
    Messages:
    786
    Likes Received:
    389
    Yes the errors are gone when i said archive in xcode. Thank you! 3Hmm I actually never use mediation at all I just use straight applovin or chartboost Somehow I never trust mediation services there was one i dont remember its name it always showed its own ads instead of admob or chartboost so didnt like it. is the situations same with heyzap? are you happy with it? I also do not xopy any sdk folders inside project folder etc for appllovin also for admob since i think they are more fot.rewarded ads. if i were t use heyzap as mediation for.full screen ads only do o have to do all that process in your tutorial?
     

Share This Page