Apple Mach O Linker Problem.

Discussion in 'Technical Discussion' started by adrogdesigns, Dec 3, 2017.

  1. adrogdesigns

    adrogdesigns Avid Boxer

    Joined:
    Dec 5, 2016
    Messages:
    318
    Likes Received:
    233
    So i accidentally opened a bb file in 2.3, i was planning an update to my game.
    But forgot i had been playing around with bb 2.3.
    But anyway things happen.
    All is fine with bb 2.3.
    except when exporting and trying to run.
    Everything runs fine without Ads, but as soon as i ad adnetworks i get apple mach o link error, unable to find adnetwork sdk's .
    Im not sure on how to fix this, if anyone has any idea on how to fix this, that would be great.
    Thanks...
    @Andy @Christoph @AaroArts sorry to tag you guys, but you are normally all over everything with fixes, thanks..
     
  2. wesam_badr

    wesam_badr Miniboss Boxer

    Joined:
    Oct 10, 2015
    Messages:
    1,063
    Likes Received:
    479
    I also ge this error when I added applovin
     
    adrogdesigns likes this.
  3. Christoph

    Christoph Miniboss Boxer

    Joined:
    Oct 4, 2015
    Messages:
    2,808
    Likes Received:
    2,308
    To be honest, I haven't used 2.3 for releasing so I can't really help. I asked this very same question in other threads (if ad networks are already enabled for production purpose), but never got an answer. I do know though that @DariusGuerrero used 2.3 for his novel and is using Heyzap without any issues, so he might be able to help. The error 'Apple Match O Linker' is a very common error, it could be anything. From wrong code to wrong SDK to not having selected any developer team. Also, BB2.3 needs Xcode 9 or still 8? Not sure...

    Edit: Also make sure you have all correct export modules. I have had problems switching between 2.2.x and 2.3 and sometimes when I imported my project into Xcode I got this error as well. After double checking the modules and exporting again they disappeared.
     
    adrogdesigns likes this.
  4. adrogdesigns

    adrogdesigns Avid Boxer

    Joined:
    Dec 5, 2016
    Messages:
    318
    Likes Received:
    233
    thanks.
    yea re installed modules, it runs fine without ads, but as soon as i ad them i get this problem.
    and yea I'm using Xcode 8.2.
    thanks for your time.................
     
  5. AaroArts

    AaroArts Miniboss Boxer

    Joined:
    Jun 22, 2016
    Messages:
    1,532
    Likes Received:
    815
    Yeh, that’s a very common error in Xcode.

    I suggest reexporting from BB2.3 and adding the latest GoogleAds SDK manually, (just copy and paste to replace the existing one in the Project folder before opening in Xcode).
    Then clean and build.

    Ninja Dive was released with 2.3 Beta 2 with Admob banners and video Interstitials but I had to update Google Ads SDK to the latest.
     
    Christoph and adrogdesigns like this.

Share This Page