App Crashing On Android

Discussion in 'Technical Discussion' started by MoveMontes, Oct 17, 2017.

  1. MoveMontes

    MoveMontes Boxer

    Joined:
    Oct 16, 2017
    Messages:
    2
    Likes Received:
    0
    Hello fellas. I exported a signed APK from Eclipse but the game crashes. Then I exported from Android Studio and the same happens.

    The crash: i just touch at the icon and the game opens for 0.5s with a black screen an then closes. In my friend's phone it shows "CoptBoy has stopped".

    Please somebody help!
     
  2. noahcdesign

    noahcdesign Avid Boxer

    Joined:
    Oct 10, 2017
    Messages:
    104
    Likes Received:
    44
    Have you updated all sdks inside eclipse and are there any errors? What version of Buildbox are you using?
     
  3. mobo12

    mobo12 Boxer

    Joined:
    Sep 19, 2017
    Messages:
    10
    Likes Received:
    0
    I am also having same issue , I am using BB 2.2.9 and JDK 1.7 (1.8 is also installed on my pc). Using SDK buildtool 25.2.3
     
  4. marinko

    marinko Boxer

    Joined:
    Oct 6, 2017
    Messages:
    4
    Likes Received:
    0
    I had the same problem, uncheck encryption(in game settings) solved problem.
     
  5. jcalle

    jcalle Miniboss Boxer

    Joined:
    Sep 25, 2015
    Messages:
    1,183
    Likes Received:
    531
    Uninstalls all Java versions, restart PC, and installs only Java 1.7.
    Buildbox only recommend Eclipse and Java 1.7.
     
  6. mobo12

    mobo12 Boxer

    Joined:
    Sep 19, 2017
    Messages:
    10
    Likes Received:
    0
    eclipse oxygen 1A need jdk 1.8
     
  7. shayeb

    shayeb Boxer

    Joined:
    Apr 2, 2017
    Messages:
    37
    Likes Received:
    0
    can you please post the links for the downloads
     
  8. jcalle

    jcalle Miniboss Boxer

    Joined:
    Sep 25, 2015
    Messages:
    1,183
    Likes Received:
    531
  9. sharma.shivam

    sharma.shivam Avid Boxer

    Joined:
    Oct 23, 2016
    Messages:
    180
    Likes Received:
    10
    hello @jcalle
    i am switching from android studio to eclipse.i recently watched this tutorial


    so i need to ask if eclipse oxygen can work with jdk 7 also
    which version of eclipse is recommended for buildbox 2.2.8
    eclipse oxygen with jdk 1.8
    or eclipse neon with jdk version 1.7.
    thanks :)
     
  10. jcalle

    jcalle Miniboss Boxer

    Joined:
    Sep 25, 2015
    Messages:
    1,183
    Likes Received:
    531
    Hello,
    Eclipse neon with jdk version 1.7

    I use Eclipse Luna and JDK 1.7
     
  11. rushikeshk9

    rushikeshk9 Boxer

    Joined:
    Jun 6, 2017
    Messages:
    3
    Likes Received:
    0
    I can't find the checkbocx for encryption in my BB 2.2.9
     
  12. Girraj

    Girraj Boxer

    Joined:
    Dec 28, 2018
    Messages:
    17
    Likes Received:
    2
    I made a game using buildbox 2.2.9 and export them into eclipse Luna (java 1.7) apk successfully build but whenever I tried to install in my phone it goes to crash or not open.
    In my system I installed Java 1.7 as well as 10
     
  13. Girraj

    Girraj Boxer

    Joined:
    Dec 28, 2018
    Messages:
    17
    Likes Received:
    2
    Please someone help me I will be eternally grateful for your
     
  14. Josh (Nology Games)

    Josh (Nology Games) Community Manager

    Joined:
    Nov 27, 2017
    Messages:
    869
    Likes Received:
    268
    Best tip would be to update to the latest build of Buildbox
     
  15. Girraj

    Girraj Boxer

    Joined:
    Dec 28, 2018
    Messages:
    17
    Likes Received:
    2
    Is this really works??
     
  16. Girraj

    Girraj Boxer

    Joined:
    Dec 28, 2018
    Messages:
    17
    Likes Received:
    2
    I made a game using buildbox 2.2.9 and export them into eclipse Luna (Java 1.7) apk successfully build but whenever I tried to install on my phone it goes to crash or not open.
    I also export them into an android studio (3.1) signed apk also successfully build but the same problem occurs. In my system, I have only Java 1.7 installed.
    Please help me
     
  17. spicedbeangames

    spicedbeangames Miniboss Boxer

    Joined:
    Mar 31, 2016
    Messages:
    1,379
    Likes Received:
    591
    Well - what OS is your Android phone? You need to install all the SDKs to support the Android devices from say 4.1 upwards. If you install just one SDK - the latest, it wont work on older devices that support 4.1 only
     
  18. Girraj

    Girraj Boxer

    Joined:
    Dec 28, 2018
    Messages:
    17
    Likes Received:
    2
    I installed SDK API level 23 (Android 6) and my phone's OS is also android 6.
    the problem still occurs. Actually signed APK successfully build but whenever I tried to install it show a message that APK is not built?
     
  19. Girraj

    Girraj Boxer

    Joined:
    Dec 28, 2018
    Messages:
    17
    Likes Received:
    2
    I have also the same problem dude. Can u please explain to me how you shot out this. I will be grateful to you. Thank you in advance
     
  20. spicedbeangames

    spicedbeangames Miniboss Boxer

    Joined:
    Mar 31, 2016
    Messages:
    1,379
    Likes Received:
    591
    Did you follow Zacks tutorial? I think BB needs SDK level 26, so you need that too and not just level 23.
     

Share This Page