Adjust Sdk Intergration

Discussion in 'How Can I...?' started by onetap, Jul 13, 2020.

  1. onetap

    onetap Avid Boxer

    Joined:
    Oct 14, 2015
    Messages:
    111
    Likes Received:
    29
  2. adrianjgomez

    adrianjgomez Boxer

    Joined:
    Apr 1, 2016
    Messages:
    44
    Likes Received:
    30
    I suspect that the custom analytics isn't fully integrated and that when you do Facebook it routes to a different set of classes. I will provide you with another video of how to do it differently. Stay tuned.
     
  3. adrianjgomez

    adrianjgomez Boxer

    Joined:
    Apr 1, 2016
    Messages:
    44
    Likes Received:
    30
  4. onetap

    onetap Avid Boxer

    Joined:
    Oct 14, 2015
    Messages:
    111
    Likes Received:
    29
    Can confirm this worked perfectly, thank you a million times!
     
  5. Nihat

    Nihat Serious Boxer

    Joined:
    Jun 29, 2016
    Messages:
    552
    Likes Received:
    154
    Thanks a lot for the videos
     
  6. volcank

    volcank Serious Boxer

    Joined:
    Oct 8, 2015
    Messages:
    734
    Likes Received:
    348
    Hi @adrianjgomez wonderful tutorial and thank you for this. Only ( maybe I missed in your tutorial) in the following link:

    https://github.com/adjust/ios_sdk

    It asks for us to import certain frameworks.
    ---------------------------------------------------------
    Add iOS frameworks
    Adjust SDK is able to get additional information in case you link additional iOS frameworks to your app. Please, add following frameworks in case you want to enable Adjust SDK features based on their presence in your app:

    • AdSupport.framework - This framework is needed so that SDK can access to IDFA value and (prior to iOS 14) LAT information.
    • iAd.framework - This framework is needed so that SDK can automatically handle attribution for ASA campaings you might be running.
    • CoreTelephony.framework - This framework is needed so that SDK can determine current radio access technology.
    • StoreKit.framework - This framework is needed for access to SKAdNetwork framework and for Adjust SDK to handle communication with it automatically in iOS 14 or later.
    • AppTrackingTransparency.framework - This framework is needed in iOS 14 and later for SDK to be able to wrap user's tracking consent dialog and access to value of the user's consent to be tracked or not.
    • ---------------------------------------------------------
    The only one I couldn't manage to import is apptrackingtransperancy framework other than that I used like this inside appdelegate.mm

    #import <AdSupport/AdSupport.h>

    #import <CoreTelephony/CoreTelephonyDefines.h>

    #import <StoreKit/StoreKit.h>

    #import <iAd/iAd.h>

    and when I try to import apptrackingtransperancy like this:
    #import <AppTrackingTransparency/AppTrackingTransparency.h>

    It didn't like it. However without it even Adjust is integrated properly cause it didn't give error and said adjust is running in production mode cause I set the environment to production. Only I would appreciate if you could help me in the above apptrackingtransperancy issue. You think this can be because of my Xcode version "Version 11.4.1 (11E503a)" and I need to update to latest because of ios14? Thanks.

    Thanks again for this tutorial and best

    Volkan
     
  7. adrianjgomez

    adrianjgomez Boxer

    Joined:
    Apr 1, 2016
    Messages:
    44
    Likes Received:
    30
    @volcank
    1. When it tells you to import you don't need to add them to the top of the file. Those are references to the libraries if you are going to use them in your code. Since you are not using them in your code they are not necessary. If you check in the build phase of a generic Buildbox export it already has those libraries.
    2. AppTrackingTransparent framework is a new framework introduced in XCode 12 to support the new attribution mechanism of iOS 14. XCode 12 at the time of this writing is at beta 5. That framework is not available in XCode 11 yet (and it might never be).
     
    volcank likes this.
  8. volcank

    volcank Serious Boxer

    Joined:
    Oct 8, 2015
    Messages:
    734
    Likes Received:
    348
    Hi thanks for the reply and yes I also thought that might not be available in Xcode 11. Only I am wondering not importing the "AppTrackingTransparent framework" would affect on the apple review since they now will want all the apps and games suitable for ios14. Now even admob emailed me for updating my SDK for ios14. But if you say that is not necessary then I will leave it like that. Thank you.
     
  9. adrianjgomez

    adrianjgomez Boxer

    Joined:
    Apr 1, 2016
    Messages:
    44
    Likes Received:
    30
    Never said AppTrackingTransparent is not necessary to link in your project, just that it is not available in xCode 11. I have not bothered for my games because I don't have space on my machine for random Apple betas.
     
  10. Mark Vass

    Mark Vass Boxer

    Joined:
    Mar 25, 2020
    Messages:
    1
    Likes Received:
    0
    Hello, I have the same problem, but I need to integrate the Adjust SDK in Android Studio, and I didn't find nothing on Google about that... please help me
     

Share This Page