0
0

I added the Application ID and Leaderboard ID to the settings page and made a Game Services button on my game, but it doesn't make me login to Google at application start and the Game Services button does absolutely nothing. Is there something I didn't do right?

Also once I do get Game Services to work, how exactly do I link to my leaderboard? I don't see the option anywhere and its not in the manual. I've searched Google up and down for how to link to the leaderboard to no avail.

Thanks in advance.

Nick

  • You must to post comments
0
0

I've been having the same issue, but I think I might have solved it. Every time I make an update to my game, I export it into a new folder, then I copy all of the folders except for /res/ because in my updates, the resources generally don't change. But, my App ID for Google Play services is in the strings resource file /res/values/strings.xml and because I didn't originally build with that ID, my new version never gets the updated string resource file with the app id. So now that I have added that, my app is working fine and it connects to the leaderboard and services :)

This might not be the case for you, but I was having the same problem: I would press the Game Services button, and nothing would happen.

Hope this helps!

  • You must to post comments
0
0

Most of this is best explained in the upload guide for Android at buildbox.com/guides. But I believe you are a paid customer, so to help figure out what is the exact issue with this please email support@buildbox.com

  • nickthelibra
    I followed the upload guide to a T. There's nothing in there that explains how to actually implement the leaderboard into your game. I could be wrong, if so, could you link me or highlight the part that I missed? From what I seen, it just tells you how to set it up through Google Play Developer Console and place the IDs for Game Services and the leaderboard in Buildbox settings. And the problem with Game Services doing nothing when the button is pressed in game (and Game Services not attempting to login when the game is started) isn't covered in any of the documents. I believe to have followed the directions perfectly, I hope. If I've missed something would you mind pointing it out? I emailed support. Still waiting for a response. Just thought I might be able to get an answer from someone here sooner, as support takes a day or two to respond. Thanks! Nick
  • You must to post comments
Showing 2 results
Your Answer

Please first to submit.